Showing results for 
Search instead for 
Did you mean: 

Sometimes devices get APIPA address but only on certain APs

New Contributor II
I have about 30 zf7982 APs spread around the campus.

On three of these APs, they sometimes give every single client an APIPA address, and other times it works perfectly normal. When it starts giving APIPAs, it happens to everyone connected to that AP, for pretty much the whole day.

If I take a device getting an APIPA and walk down to the next AP, the device instantly connects  on the appropriate VLAN and gets an IP address. If I walk back to the AP causing problems, it disconnects from wifi as soon as it connects to that AP and then gets an APIPA.

Restarting the AP sometimes fixes the issue, until it happens again which could take anywhere between a few hours to a few days.

I am having this issue on Macbooks running 10.10.5 all the way to 10.14.6, iPad Air 2s running iOS 12.2+ and iPhones running 12.2+.

I am using a ZD3050 build 42. The ZoneDirector does not handle DHCP. I use a MacOS server to handle DHCP for teachers and students, and a Fortigate to handle DHCP for admins and IT.

Our radius server is also handled by a separate Mac OS server running 10.6.8

In one part of the building I took the AP down and the issue appeared to have stopped. I put it back up and the problem came back. Some trouble shooting steps I have tried.

1. Factory Reset the problem APs
2. Manually assigned channels to all APs
3. Testing the ethernet cables
4. Adjusted the bss-minrate
5. Adjusted the TX Power

Any advice on next steps or what to look for would be helpful. I am inclined to say its a bad AP since this has been an issue for a few years now. The logs from Ruckus ZD aren't particularly useful, at least nothing has stood out to me.

I would suspect a switch issue....
APIPA is self-assigned by a device when its DHCP request times out.
The devices seem to connect to the SSID fine, so I would say, the AP is managed ok and it accepts clients. The issue is that the devices don't get DHCP.
Either the switch is dropping the tagged packets for the VLAN the client SSID is assigned to, or most likely the DHCP request packets are miss-routed or are answered wrong by some rogue DHCP server, or the DHCP server is out of leases, or it doesn't have a scope defined for the subnet the client seems to be coming from etc.....
I would mirror the switch port and capture the packets to see what is going on.

Of course this hasn't happened since I posted this, but I got it setup and will do a packet capture the next time this occurs. Thanks for the suggestion.

New Contributor II
Little bit more information I was finally able to get today.

I got the DHCP logs from my server and it is not getting any DHCP request from the client. Tried multiple times by turning off the wifi and turning it back on.

However, once I forgot the wifi network on the client and re-entered the wpa2 password, it instantly got a DHCP address. Checked the server logs and it got the request and sent the ACK.

Wasn't able to get packet capture info on this one. I tried to get the packet capture from the AP itself which didn't show anything out of the ordinary.

Also, while the issue is happening the device is getting tagged in the proper VLAN, so I don't think its the radius.