Showing results for 
Search instead for 
Did you mean: 

R310 country code problem

New Contributor
Hi, my name's Serge and I'm new to this forum.

I have a problem with an unleashed setup.

I had a 3 APs setup and I bought 2 new ones. I was struggling to get the new APs to work with the existing Unleashed installation and I did several thing, the first i did was to upgrade all the firmware's of the APs to the latest available, that didn't helped, so reading every post I could find I saw someone saying something about the country code.

So I decided to change the country code in one of the New APs to match the current installation, using SSH with the 'get countrycode' command it showed it was set to US, using the command: 'set countrycode CO' I was able to change it to CO since that's the current country code of the Unleashed installation. Making that change allowed the AP to show up in the Unleashed dashboard.

Then I tried to do the same in the other New AP but this one said 'illegal to change country code', I tried factory reset using the reset button and the 'set factory' command with no luck.

I decided to change (from the master AP) the whole Unleashed to US but now the first New AP (the one that I was able to change from US to CO from CLI) is Stuck in Country code CO and won't get back to US, trying to execute the set countrycode US command says 'illegal to change country code', how come I was able to change it then but not anymore?

Both New APs are 9U1-R310-US02

Please helpme if I don't manage solve this I'm going to be in big trouble.


Valued Contributor
Hi Sergio,

Based on the part number you provided, 9U1-R310-US02 you have bought the US version of the AP as it says in the part number and not the WorldWide version (WW).

The US version is locked for the US only.
If you are not in the US, then bring the units back to your supplier and ask the WW version.

Kind regards