Showing results for 
Search instead for 
Did you mean: 

Issues configuring VLANs on Single AP Deployment of 7372

New Contributor II
Hi Everyone,

As a preface, I worked with Ruckus support directly on this issue and the tech stated that my configuration looks correct and it might be the AP, but I am having this issue on another AP as well.

In short, when attempting to connect to either of the SSIDs from the AP, it sits at the point where it states "Obtaining IP Address" but the device never hands out the address.

In this environment, I have a SonicWall NSA 220 with two VLANs configured as 10 and 20. The 10 VLAN is for the corporate WIFI and is a seperate subnet from their primary subnet. The same is true for VLAN 20 as well but this is another subnet for the guest network.

DHCP is turned on on the SonicWall for both of these VLANs. The AP is connected to a 1900 series HP POE switch on port 9 which is untagged on VLAN1 (default VLAN) and has tagged memebership on VLAN 10 and 20. Then on the AP itself, obviously each SSID is specified to use the specific VLAN.

I simply can't figure out why the hell this device is unable to assign an address out from the WAP. Does anyone have any ideas or can maybe set me on the right path? Please let me know if you require more information.

Did you configure the port the SonicWALL is connected to correctly? Fire up a packet monitor and see what’s going on—if your switch supports it, port monitoring/mirroring might be helpful. Start tracing the path—for example, do you see a client broadcasting a DHCPDISCOVER packet? Does the SonicWALL receive this DHCP packet? Is the SonicWALL replying with a DHCPOFFER? I have a similar configuration at home with a single 7982, HP PoE switch and VLANs with zero issues.

New Contributor II
On the switch, the port that the SonicWall is connected has the same membership to to the VLANs as the WAP.

Sounds like I might have to start doing some port mirroring to track this issue down but I was hoping to avoid that.

I too have had zero issues previously doing this same exact configuration for other clients on the 7363's with nearly similar hardware setups.

New Contributor III
I am guessing that you get an IP from an access port on the switch that is in either VLAN 10 or 20. That would rule out the switch and sonicwall. I am also guessing that you have all of the trunking set up correctly on the switch with regard to the VLANs and any DHCP snooping if you are running that.

I have a 7372 set up the same way and don't have any issues. I have the Ethernet ports set as trunks and don't have option 82 enabled as that caused issues with my switches dhcp snooping. I then has some SSID's tagging on seperate VLANs and some riding on the default VLAN untagged.

Have you tried a static IP on you wireless client to see if its just a DHCP issue?

New Contributor III
Try this command

set interface type vlan-trunk untag none, where interface is the interface connected to your switch.