Showing results for 
Search instead for 
Did you mean: 

Enabling multicast for a Sonos environment

New Contributor II
I am having trouble with a ZoneFlex R510 in standalone mode, and integrating Sonos. In a nutshell, I can't get the Sonos hardware to join the 2.4Ghz network. Here is a relevant discussion on the Sonos forums. I spent hours troubleshooting this last weekend. When I put my old WAP in place everything worked fine. Re-introduce the Ruckus equipment and it falls apart again. It sounds like I need to try enabling multicast traffic?

Is this an option in the Web GUI or a CLI only thing? I started looking into this last night and did not find any clear steps. The AP is running v200. software.

New Contributor II
Nobody, eh? So I need to call support?

New Contributor III

Last post will fix your issue providing you have no other networking issues

New Contributor II
Thanks for the post. The syntax of those commands is different for Unleashed? They did not work for me when I was connected to the AP via SSH.

Here is the translation. Or at least the commands that executed successfully for ME.

The first command was supposed to be this:

rkscli: set qos directed multicast disabled

Should be:

ruckus(config-wlan)# no qos directed-multicast

The second command was supposed to be this:

rkscli: set qos eth0 igmp disable

Should be:

ruckus(config-wlan)# no qos igmp-snooping

The third command I could not figure out.

rkscli: set qos eth0 classification disable

I tried digging into the system configuration and entering this command, which is the ONLY QoS setting I could find in the Unleashed CLI:

ruckus(config-sys)# no qos
Changes are saved!
System QoS function has been disabled

However, after entering this series of commands I am still not able to join my Sonos hardware to my Ruckus WiFi network. The error presented by the Sonos controller is to make sure the 2.4 Ghz WLAN is 802.11b/g compatible.