cancel
Showing results for 
Search instead for 
Did you mean: 

Zonedirector 1100 firmware upgrade issue

heart_l3ss
New Contributor II
Hello,

I have been struggling to upgrade the firmware of my ZD1100 to the latest firmware.
At the moment, the device is on the 9.6.1.0.15 firmware. I would like to upgrade this to the latest, however no matter what I tried, it seems impossible. 
At the start, I tried to go straight to the last version which ended up getting stuck at 0% upgrade progress.
Then I found out about the "correct" upgrade path to follow until I reach the desired latest version. However, no matter how many earlier versions I tried, even the exact next version, all upgrades get stuck at 0% with a red blinking status LED.
I left it 2 times to do the upgrade overnight and it was still stuck when I woke up, 8 hours after.
Any advice? 

Thanks for your time in advance.
Have a great day! 🙂

8 REPLIES 8

Ankush_Chandan
Contributor II
Hello,

Could you ensure you are using one of the supported browsers to upgrade:
Image_ images_messages_5f91c455135b77e247a2cbe4_1eb5687cf8fe2d8ba1021662d239c28f_RackMultipart201905311020151cy-d89dc904-5aa0-4724-8d2a-eba99bf4f49e-1020014239.png1559314611

Alternatively, you can try upgrading your ZD via CLI. For reference, please find a quick How-To-Hub Video on how to upgrade ZD via CLI:
https://youtu.be/Sg_fjpaiIbM


Regards,
-Ankush

michael_brado
Esteemed Contributor II
I recommend that your laptop with the firmware image be on the LAN with your ZD. 


Try the next level FW upgrade first, ie 9.7.2.0.9:

https://support.ruckuswireless.com/software/599-zd1100-9-7-2-0-9-mr2-software-release

heart_l3ss
New Contributor II
The thing is that the firmware that the ZD has, is so old, that I cant access it from any modern browser for security reasons. I have 3 computers and they all run Win8.1 and later OS. 
So I had to create a Windows 7 virtual machine and open the web UI of the controller through Internet Explorer with all older SSL settings, else the page would never open for security reasons. 

Of course the laptop is on the same network. I tried with both the laptop and ZD on the main network and also by themselves without any connectivity to the router or main switch. 

I will try to do both of the things you suggested, CLI upgrade and try the 9.7.2.0.9 version.

Thank you all so much for your time!
I will get back to you with the results!

mitchell_axtell
Contributor II
If you do use the browser again, make sure to add the site to the compatibility view list or upgrading the ZD from IE will corrupt the firmware.  You can use IE11 on Windows 10, and it should function if you enable SSLv3.