cancel
Showing results for 
Search instead for 
Did you mean: 

This site can't provide a secure connection ; 192.168.90.2 uses an unsupported protocol ; ERR_SSL_VERSION OR CIPHER MISMATCH

dax_gonzaga
New Contributor II
Hi All,

Just wanted to ask if someone encounters this issue, when I connect to ZD 1200 through wired and try to open it via google chrome I cannot open it. It states there that "This site can't provide a secure connection. 192.168.90.2 uses unsupported protocol. ERR_SSL_VERSION or CIPHER MISMATCH". I can ping ZD 1200. I open web browser like edge and IE same issue. Hopefully someone can  give an advise. Thank you
7 REPLIES 7

zoran_marceta
New Contributor II
Hi,
what software version do you have? I also had same issue with my ZD1100. Software version was 9.6.0.15. I upgraded to 9.8.3.0 and problem is solved. 
All the best

Hi Zoran,

Thanks for the reply

What web browser are you using when you upgraded your ZD 1100? Because I want to upgrade my ZD as well but I cant get in via chrome, IE and Edge.

Have you tried Mozilla ? Or do you have older IE anywhere. I had one server with older IE.

Haven't tried Mozilla yet. I will try Mozilla or older version of IE if it works. If i can access my ZD I will upgrade it to a higher version.

Thanks Zoran
Labels