cancel
Showing results for 
Search instead for 
Did you mean: 

Remove Google Maps

matt_pawsey
New Contributor
We recently updated to ZoneDirector version 10.3.0.0.362 and now have the Google Maps error on the dashboard "Google Maps is not working due to an API key problem. If this problem persists, you may need to add a valid API key." We don't want to buy a maps API key, and all our APs are in one location so it would be useless anyway.

We can click "Hide Map" but then it just comes back as soon as the browser is refreshed. Is there any way we can permanently remove this, as it takes up the majority of the space on the dashboard?

Thanks for any help
5 REPLIES 5

victor_gonzalez
New Contributor II
Hello, I do not know if in ZD it is similar to that in vSZ, in vSZ it can be hidden by clicking on the gear that appears on the upper right side, in the same line of the Health heading, here the MAP option appears ON, set it to OFF and It should no longer appear.

Regards

charles_sprick1
New Contributor III
I have a feeling there's no way to make it stick. There's all kinds of settings that seem to last no longer than the duration of the session. I'm constantly rearranging/resizing columns, re-ordering things, adding/removing column headers and they never seem to stick.

One option that gets rid of the error is moving to Bing Maps. They still offer free keys. I even got a $100 gift card for answering a survey on my use of their Maps product. 🙂

You don't need to buy an API key unless you're loading the map hundreds of times a day. Unless for me, it was super simple to get the API key. I believe also that if you don't reload the map page it's a single API call for the whole day

dinyero_johnson
New Contributor
I wonder if there could be a move to OpenStreetMaps. Many of the open source network management platforms have allowed this as an alternative to Google or Bing and it works well.
Labels