Showing results for 
Search instead for 
Did you mean: 

no DHCP discover via vSZ AP

New Contributor III
Dear all,

I have a question regarding DHCP leases with R500s connected to vSZ-H. We a management domain with two AP zones working right now in the vSZ. The vSZ is in the cloud and those APs are running at a customer site.

Now, I wanted to create a lab environment and created a new management domain, new AP Zone and WLANs. The AP provisions just fine, but when i try to connect with my devices to the WLAN, I don't receive an IP. Checking packets on our router/firewall in the netwerk reveales no DHCP discovers are being received on that device (which also runs the DHCP server). When i connect to a separate AP that is not in our vSZ and i can immediately see DHCP discover, offer, request and ACK and I'm live.

Our lab is fairly simple. Two APs connected to a small office network and they're directed towards our cloud vSZ. My first test WLAN had a VLAN ID of 1, which puts it in the native VLAN, or simply put, no VLAN tag is attached. Since that didn't work, i created a 2nd VLAN with VLAN tag 2, but also doesn't seem to work (we do have VLAN 2 with DHCP on the gateway).
I've also tried without and with WPA2 encryption.

Any reason what would stop the AP from sending out DHCP messages to the gateway? Also, is there a packet capture possibility on the R500 with vSZ firmware? I want to eliminate my switch as a potential issue (although, I dont believe it is due to the simple config on the thing).

Kind regards.

PS. our vSZ does management traffic only, no client traffic tunneling. The above WLANs are a simple as possible.

Esteemed Contributor II
Werme, the AP does not "send out DHCP messages".  It only puts WLAN traffic onto the Ethernet interface, with the VLAN tag assigned by the WLAN.
Your switch must support (trunk) that VLAN too if it's not the native VLAN, and there must be a DHCP server that provides DHCP for that other VLAN.
Does this make sense, or do you have a local VAR to discuss your networking with?

New Contributor III
Hi Michael,

You're right. Technically I misdescribed the issue. What i meant to say was that the AP wasn't putting my clients DHCP discover packets onto the Ethernet. It looked like the traffic was just not exiting the AP, whereas on my laptop with wireshark, I could see that the traffic was generated towards the AP.

The problem is, I resetted the AP, reconnected it to the vSZ. Also, on a separate occassion I've updated the vSZ to 3.4. Now the issue seems to be solved, but I can't pinpoint what the cause is/was, neither can I recreate it.
Seems like a weird bug somewhere. And yes, I did absolutely make sure the AP was properly connected to the network and tested with another cable 😉