Showing results for 
Search instead for 
Did you mean: 

Apple Connection issues with Ruckus Cloud

New Contributor II
Over the last few months I have noticed that Apple devices have connectivity issues with Ruckus Cloud APs. Macbooks, AppleTVs, iPhones, the whole gambit. I am seeing it at different physical locations too, so this leads me to believe it is not location specific. I also do not see this with Unleashed or ZoneDirector networks. Client events often show that they were "disconnected due to lack of activity," however I have personally watched a user get disconnected while streaming from multiple sources. I am also noticing errors related to handshake, dhcp, or 802.11 authentication. I'm not sure how much I trust this information though. Has anyone had this issue and/or have solved it? So far Ruckus Support has said there is nothing wrong with my configuration......

New Contributor II
Hey there, I am a Mac user and Ruckus reseller. My personal experience is that I have Ruckus Cloud Wifi in the office and I have it at home for the past c. 2 years. In the office we have 9 users and 3 APs and just a single AP at home for family. In the office everyone has an iPhone and there are a couple of iPads and a Mac laptop (mine). Lots of guest users. At home we have iMacs, iPhones, iPads. We also have many Winders PCs but on the whole we have a problem free experience with Ruckus Cloud. Same with clients some of whom are Mac 'shops' no issues reported. I have noticed the 'disconnected due to lack of activity' but I have received zero complaints. At home we have several teenage 'streamers' and trust me, if there was a glitch, I would know about it. This may not address your issue but it should add some comfort that it 'should' work flawlessly.

New Contributor II
Thanks for your reply Stephen. In my case, I can watch users get disconnected every 20 minutes or so. This means I get lots of complaints and can witness the failures in action. We do have significantly more APs and users though. Have you made any specific changes to your AP settings? I.E. channels, tx rate, connectivity timer? Or are you running it with the default settings? Nothing I try has seemed to help.

Valued Contributor
Hi Chris,

My experience is much the same as Stephen's.  I'm running Ruckus Cloud on 5 APs with multiple kinds of devices including MacBook Pro (2017), iMac 27" (2013) iMac 27" (2009), iMac 24" (2010), Home Pod, iPhone XS, 8+, 6S, 7, iPad Pro ... all with no issues.

Have you tried an SSID with a completely new configuration profile?

Are there any other centralised services on the network that could be at fault?

Good luck in finding the issue.


New Contributor II
Hey thanks Darrel. I made a test ssid and seemed to have issues with that too. If there are any other centralized services causing this issue I have no idea what it could be, especially since this issue seems to be happening at different physical locations with their own network. I've gone through dhcp, I've adjusted the channels for other devices in the area, etc.

When you view client events do you see any errors under connection attempts? Marked by the red hazard triangles? Because it my case it appears as alternating connection succeeded / connection failed for mac users.