Showing results for 
Search instead for 
Did you mean: 

SNMP set giving undo failed error on the icx switch

New Contributor III

I want to untagg the port 2 in VLAN 1050. Initially, it is untagged in VLAN 1025.

Request to set the row as “untagged” (untagg port 2 in VLAN 1050)

print_r(snmp2_set('HOST', 'test12345', '', 'i', '2'));

Gettting error: Warning:  snmp2_set(): Error in packet at 'SNMPv2-SMI::enterprises.1991.': undoFailed 

I have also tried using the following SNMP OID:


The above calls are also failing and I am getting a no response.

Any suggestions?

New Contributor III
Hi Isaac,

I have tried using the above SNMP calls but I am getting the following errors:

Warning:  snmp2_set(): Error in packet at 'SNMPv2-SMI::enterprises.1991.': undoFailed
Warning:  snmp2_set(): Error in packet at 'SNMPv2-SMI::enterprises.1991.': undoFailed

Port = 2
VLAN = 1050

I have removed the port 2 from VLAN 1025, but still getting the above error.

Please suggest!

Thanks for your reply on this.

RUCKUS Team Member
Hi Amar,

Were you able to use both OIDs on the same call? is that something supported for the tool you are using, from previous tests I know that not all SNMP tool support that, is there a way for you to test with net-snmp tool? 


Hi Issac,

I was successfully able to untagg the ports after using both the OIDs in a single snmp call.

Thanks for your suggestion. I really appreciate.

Great!! Amar, I am glad to hear that, thank you for the confirmation 

New Contributor II
Hi Isaac,

I have similar problem like Amar. I have successfully add vlan to tagged port, but have problem with adding vlan to untaged port
snmpset -v2c -c community i 4 i 2

and i get error like that

Error in packet.
Reason: undoFailed
Failed object: SNMPv2-SMI::enterprises.1991.