cancel
Showing results for 
Search instead for 
Did you mean: 

Android's 11 are requesting Domain

fepam_unipam
New Contributor II

Some SSID settings are EAP, MCHAPV2, WPA2. Cell phones with Android 11 are requesting Domain, I tried to put the address of the freeradius and the controller and it didn't work. Here we use FreeRadius 2.2.3, and as Wi-Fi controllers the Virtual Smartzone 5.2 and Zone Director 9.12.3.0 build 105 for more AP's old. Can anyone help? The only configuration I found, in VSZ, of domain, is in Clients -> Wireless Clients -> System. Then the domain name is system.

4 REPLIES 4

danielslztorres
New Contributor

Hi!

This is a WPA3-Enterprise issue. You have some options to solve this problem.

1 - Install root CA certificate used in FreeRADIUS on clients. Then use certificate's domain.

2 - Use a certificate issued by a trusted CA.

Respectfully,

Daniel Torres - Telecommunications Technician

As for the first option. You say I should install FreeRadius certificate on every cell phone with this problem? Should I make this certificate available on our company's Wi-Fi settings manual page?

Important detail: always, in the certificate option, we leave it as 'do not validate'.

 

danielifmamtc
New Contributor

Not the freeRADIUS certificate, but the certificate's Root CA. You may make it available to be downloaded and installed by the end user, putting this in the manual page. Or, you can develop an app to delivery the certificate automatically.

In my case, it was possible to issue a trusted certificate. It makes implementation much easier, because the only additional instruction is "type the domain".

danielslztorres
New Contributor

About the certificate option, in Android 11, there's a second validation (online). For both, still choose 'do not validate'.