cancel
Showing results for 
Search instead for 
Did you mean: 

CloudPath SaaS EAP-TLS computer authentication

vadim_matusovsk
New Contributor

Hello,

I have implemented an Unleashed solution with ICXs, R320s, and CloudPath SaaS.

We are a cloud native org, and using AAD as IDP for our applications.

We are using AAD with CloudPath utilizing SAML for integration and user authentication for onboarding to WiFi.

The process is simple, the user accesses the Cloudpath onbaording URL, gets redirected to AAD, authenticates, and downloads the app for the Certificate and WiFi configuration.

All our users are using Windows 10 devices.

I have noticed that when Windows boots up, it is not connecting to WiFi, after the user logs in, the WiFi connects.

I have investigated this, and found the the authentication is a user authentication, and this explains the behavior.

I would like to change the EAP-TLS to computer authentication, so that WiFi could connect before the user logs in.

Could you advise please ?

Thanks,

Vadim.

10 REPLIES 10

christopher_moh
New Contributor III

Hello Vadim,

You can modify how the certificate is installed on the device by opening up:

  1. Configurations
  2. Device Configurations
  3. Select the Device Configuration that you want to edit by clicking the disclosure triangle to the left of it
  4. Click on the OS Settings Tab
  5. The first entry is for "Windows Settings"
  6. Click the Pencil beside "Configuration from the Network(s) and Trust tabsConfiguration from the Network(s) and Trust tabs" in the Windows Settings table
  7. In the Advanced menu, you can modify WLAN and Certificates for User/Machine.
Image_ images_messages_6099604deae73941980eddf0_affecce30f33b009013bb043152ebac1_deviceconfigmachineauth-e3e3b012-7277-49b6-9707-d7603cb81aee-372939250.PNG

Regards,

Christopher

pierce_larsen
New Contributor II

Vadim,

You can change this in your device configuration. In Cloudpath admin UI, go to Configuration-->OS settings-->Windows-->Click Pencil by Configuration from the Network(s)-->Change WLAN Profile Type and Certificate Store to "Machine" and "Machine"-->Change Authentication Mode to "Machine Only"

If Authentication Mode isn't set to "Machine Only" then either it won't work pre-login or post-login with no user cert.


If you change to the settings I highlighted above, then it should work both pre and post login using the machine certificate.


Thanks,

Pierce

vadim_matusovsk
New Contributor

Hi Pierce and Christopher,

Thank you for the reply and help!

If I'm changing to an already deployed configuration, will it affect the user that were already deployed with the User authentication ? Or it wont affect the already deployed, and only affect future deployed only with "Machine Only" ?

Thanks again,

Vadim.

vadim_matusovsk
New Contributor

Hey,

Any advise ?

Thanks,

Vadim.