Showing results for 
Search instead for 
Did you mean: 

R300 & R500 WAP installed have the same SSID. How can I get mobile devices to connect to the WAP with the best signal automatically?

New Contributor
Hi. I have an R300 & R500 WAP installed at a site to stream audio. Both have the same SSID. Does anyone know how I can set them up so that the customers mobile devices will connect automatically to the WAP with the best signal? (Roaming?)

Esteemed Contributor II
The decision when to roam is solely a function of the client radio drivers and supplicant, based on SNR, interference and other factors.

Some client roaming behavior has been described as "sticky" or wanting to remain on the first AP it connected to a particular SSID.

In general, having two APs at a sufficient distance apart, both advertising the desired SSID, will attract the clients that are closest to the AP(s).

In addition, you can also increase the minimum communication rates the AP's will provide before they force a disconnect.  This can be useful for "sticky" clients roaming between APs.  It will push disconnects to them when the signal gets very low so they will connect to a better AP.  The detriment is that your total area of coverage (the fringe) is reduced because you're not supporting the lowest communication rate allowed.  This is commonly not a problem in office environments with awesome coverage where the wifi blows out the side of the 18th floor (you're not going to ever see the fringe 18 floors up 50 yards out).

SMARTRoam can do the trick in this situation which kicks off STA connecting on poor threshold however i am not sure if that would work in a standalone mode..

i know that it certainly works in ZD controlled environment and VSCG...

Valued Contributor II
Smart Roam is available in standalone:

However, my experience is that clients don't like to be kicked off a wireless network in this manner. If you are streaming video or making a VOIP / wifi call, it stops the video or drops the call, and the client may wait quite a while before attempting to reconnect to the network.

I wouldn't turn on SmartRoam for modern clients unless roaming is really really a problem.