Showing results for 
Search instead for 
Did you mean: 

POE error after power cycling ICX 7150 C12p

New Contributor III

**EDIT 4 JAN 2021** Got my ICX 7150 C12P replaced with RMA after it was determined that there was a POE hardware failure of some kind happening.

I have two R510s connected to my Ruckus ICX 7150 C12p switch. Was working fine for months. Last night I disconnected everything to clean up and organize my comm rack. When re-connecting everything to the same ports they came from (I labeled them), POE will not start for my 510s and I see this error in the system log:
Error: PD on port cannot be powered due to power being injected on another port of this unit.
I ran the command "no inline power" on all the ports of the switch and re-enabled just the two that need it, and fiddled with the CLI endlessly last night for hours but no dice. The switch is working fine otherwise, thankfully. Any ideas why the APs decided to stop working or what's going on here? I did have a fair amount of customization on the APs, with a vlan and a bunch of rogue AP blocks in place, and it was tied in to the switch, as it shows the switch on the unleashed app, at least when they're working.


Valued Contributor II

Seems you have cable connecting this port and some other port on same switch. I recommend connect some device (AP, camera, etc.) to that port directly (using direct patch), to be sure there are no issues with cabling. If still get same message, I would disconnect cables from all other ports, and tried again. If still same message, than it is switch fault. But as you described events, I strongly suspect it is incorrectly connected or faulty cable.

Hope this helps

I've removed all ethernet cables from the switch as a troubleshooting step, connecting only the AP ethernet runs (one at a time even) .. same error always persists.

I happen to have another ICX 7150 switch available. I've configured it to match the production unit, and I will switch them out today after COB.

If it works as expected, then I think it's the switch having a problem. I read somewhere that POE firmware can be corrupted. What would you suggest I do to fix the switch that's malfunctioning? Flash a newer firmware to it? Currently on 


Here's some data from the switch that may be useful. Flash and poe details:

SSH@S2_7150_C12P_2>show flash
Stack unit 1:
  NAND Type: Micron NAND 2GiB (x 1)
  Compressed Pri Code size = 28660224, Version:08.0.90dT211 (SPS08090d.bin)
  Compressed Sec Code size = 32539748, Version:08.0.90dT213 (SPR08090d.bin)
  Compressed Pri Boot Code size = 786944, Version:10.1.15T225 (mnz10115)
  Compressed Sec Boot Code size = 786944, Version:10.1.15T225 (mnz10115)
  Code Flash Free Space = 1188265984
SSH@S2_7150_C12P_2>show inline power

Power Capacity:         Total is 124000 mWatts. Current Free is 124000 mWatts.

Power Allocations:      Requests Honored 15 times

 Port   Admin   Oper    ---Power(mWatts)---  PD Type  PD Class  Pri  Fault/
        State   State   Consumed  Allocated                          Error
  1/1/1 On      Off            0          0  n/a      n/a         3  n/a
  1/1/2 On      Off            0          0  n/a      n/a         3  n/a
  1/1/3 Off     Off            0          0  n/a      n/a         3  n/a
  1/1/4 Off     Off            0          0  n/a      n/a         3  n/a
  1/1/5 Off     Off            0          0  n/a      n/a         3  n/a
  1/1/6 Off     Off            0          0  n/a      n/a         3  n/a
  1/1/7 Off     Off            0          0  n/a      n/a         3  n/a
  1/1/8 Off     Off            0          0  n/a      n/a         3  n/a
  1/1/9 Off     Off            0          0  n/a      n/a         3  n/a
 1/1/10 Off     Off            0          0  n/a      n/a         3  n/a
 1/1/11 Off     Off            0          0  n/a      n/a         3  n/a
 1/1/12 Off     Off            0          0  n/a      n/a         3  n/a
 Total                         0          0