Showing results for 
Search instead for 
Did you mean: 

Enabling multicast for a Sonos environment

New Contributor II
I am having trouble with a ZoneFlex R510 in standalone mode, and integrating Sonos. In a nutshell, I can't get the Sonos hardware to join the 2.4Ghz network. Here is a relevant discussion on the Sonos forums. I spent hours troubleshooting this last weekend. When I put my old WAP in place everything worked fine. Re-introduce the Ruckus equipment and it falls apart again. It sounds like I need to try enabling multicast traffic?

Is this an option in the Web GUI or a CLI only thing? I started looking into this last night and did not find any clear steps. The AP is running v200. software.

Thanks for the reply. Are you talking about this?

if it is available
Radio Resource Management:Enable 802.11k Neighbor-list Report  (enable this)
and set this to this 
Directed MC/BC Threshold:  set this to 0
(0-128)Defines the client count at which an AP will stop converting group addressed data traffic to unicast  
ruckus(config-wlan)# no qos directed-multicast
ruckus(config-wlan)# no qos igmp-snooping

ruckus(config-sys)# no qos 
Changes are saved! 
System QoS function has been disabled
no qos classification

New Contributor III

New Contributor

i have the same Problem, Sonos does not work, with the Sonos Support i could find that the Ruckus AP is the Problem, it works for me until end of April 19, ill think tghe auto update to the 207 Version kicks my Sonos out.

With this Article, i could getg it work with my

r310 unleashed

But with my R510 unleashed and my R710 unleashed, no way, i have tried everything with older Versions and the newest Version

ruckus(config-wlan)# no qos directed-multicast
ruckus(config-wlan)# no qos igmp-snooping

ruckus(config-sys)# no qos 

Does only work for r310 unleashed, has anyone a hint for me, to get my r710 and Sonos back to business ?

Thank you


New Contributor
This video might help 
From what I have seen you need to have qos directed-threshold 0 rather than the no qos igmp-snooping 
Also as Sonos works on 2.4 channel set Ruckus to only work on 1 channel rather than channel fly across the entire range.

Basically Sonos, the same as SkyQ will only want to work on there own proprietary network - Sonos call it SonosNet - I would assume Sky call it something similar but dont want the world to end 🙂 - These devices do not like communicating on a Enterprise network and as such the only certainty to get this to work is having a single Sonos unit wired and letting that connect to the other Sonos devices via there own Wireless option - think it has something to do with Multicast/Unicast conversation that isnt being liked. 

New Contributor
Hi Dan,

thank you for the Reply, i have tried qos directed threshhold 0 and no qos directed-multicast

it has no work, also i think it works with my 310 only that the Speaker have an active lease on my dhcp, right now i cant get it work even on my r310,

I know Sonos net tested it and it works, but i have no Speaker near a Network Plug 😞

Basicly i wonder it worked like a a charme to April....