Showing results for 
Search instead for 
Did you mean: 

Enabling multicast for a Sonos environment

New Contributor II
I am having trouble with a ZoneFlex R510 in standalone mode, and integrating Sonos. In a nutshell, I can't get the Sonos hardware to join the 2.4Ghz network. Here is a relevant discussion on the Sonos forums. I spent hours troubleshooting this last weekend. When I put my old WAP in place everything worked fine. Re-introduce the Ruckus equipment and it falls apart again. It sounds like I need to try enabling multicast traffic?

Is this an option in the Web GUI or a CLI only thing? I started looking into this last night and did not find any clear steps. The AP is running v200. software.

New Contributor III
Thank you and you are very welcome. I wouldn’t use a Ruckus AP with Sonos if you are selling this. Your plan is the best. Another option is to use a ZD and dedicate one AP to Sonos and then SSH into that AP and run the commands. From the controller you can put it in its own AP group SONOS 2.4 and then turn off everything but channel 1 It won’t affect the rest of your deployment for non Sonos clients.

Valued Contributor
You can type the command using "ap-mode" on ssh into Unleashed.

ruckus# ap-mode
You have all rights in this mode.
ruckus(ap-mode)# set qos

If you don't find "ap-mode", it's old versions for UAP.

If so, you can type the command using remote-ap-cli -a 'ap mac' "set qos ~~~" on debug mode into ssh of UAP.

New Contributor
Hello everyone, i'm struggling with the same issue. all the Sonos products aren't working at all. I've read all the replies above, im a bit nervous to make changes to the switch or ap with understanding the issue. If someone can explain or point me in the right direction, i'd really appreciate it. Thanks.

I have ruckus 12-port ICX switch and two R510 series APs. 

New Contributor II
I gave up on this and could never get a clear answer from anyone at Ruckus how to make this work. I now have one of the ZonePlayers connected to my switch via Ethernet and I've just let the rest of the hardware create its own little mesh network. This issue was really frustrating and I used up a lot of cycles trying to find a workaround.

I DID find lots of snide comments elsewhere about how the Sonos hardware is just too dumb to join an Enterprise WLAN.


New Contributor III
The answers are in the post. Follow them and it will work.