cancel
Showing results for 
Search instead for 
Did you mean: 

7982 APs won't join SZ100

Windsor351
New Contributor

I have a SZ100 running 3.6.2.0.222. My zf7982 are running 3.6.2.0.254 and won't join the controller.   I have a bunch of R510 &  R710s that joined just fine.   I can ping the SZ from the AP and they are on the same network.  I manually added the server IP to the AP with no luck. 

This SZ100 code supports 7982s.   Do I need to downgrade the firmware on the 7982s?  If so, which code can I down grade to?  I'm not finding anything on the Ruckus support page. 

rkscli: get scg

------ SCG Information ------
SCG Service is enabled.
AP is not managed by SCG.
State: DISCONNECTED
Server List: 10.191.145.4,
No SSH tunnel exists
Failover List: Not found
Failover Max Retry: 2
DHCP Opt43 Code: 6
Server List from DHCP (Opt43/Opt52): 10.191.145.4
SCG default URL: RuckusController
SCG config|heartbeat intervals: 300|30
SCG gwloss|serverloss timeouts: 1800|7200

Jan 12 21:55:39 RuckusAP daemon.err wsgclient[575]: registration:699 Failed to init socket! ret:121 url:https://10.191.145.4/wsg/ap
Jan 12 21:55:42 RuckusAP daemon.err gapd: Fail to get pool stats 
Jan 12 21:55:42 RuckusAP daemon.err gapd: selecting..... 
Jan 12 21:55:42 RuckusAP daemon.info idm: SCG is not ready. wsgclientState()
Jan 12 21:55:43 RuckusAP user.err MsgDist[404]: MD try connection towards SCG-MD 
Jan 12 21:55:43 RuckusAP user.err MsgDist[404]: RCSL_Connect to 127.0.0.1 failed 
Jan 12 21:55:44 RuckusAP daemon.err mDNSClientPosix: mDNS_RegisterInterface: Error! Tried to register a NetworkInterfaceInfo 169.254.17.13 with invalid mask 0.0.0.0
Jan 12 21:55:44 RuckusAP daemon.err mDNSClientPosix: mDNS_RegisterInterface: Error! Tried to register a NetworkInterfaceInfo 169.254.17.12 with invalid mask 0.0.0.0
Jan 12 21:55:46 RuckusAP daemon.info hub_registrar: OCSP: Initial curl host ap-registrar.ruckuswireless.com connection check returns failure 1536
Jan 12 21:55:46 RuckusAP daemon.err wsgclient[575]: cmrSSLlInit:171 SSL init error 5
Jan 12 21:55:46 RuckusAP daemon.err wsgclient[575]: cmrInit:144 Fail to init SSL, ret:121
Jan 12 21:55:46 RuckusAP daemon.err wsgclient[575]: communicatorInit:331 Init connection failed, ret:121, connectRetry:359
Jan 12 21:55:46 RuckusAP daemon.err wsgclient[575]: registration:699 Failed to init socket! ret:121 url:https://10.191.145.4/wsg/ap
Jan 12 21:55:47 RuckusAP daemon.info idm: SCG is not ready. wsgclientState()
Jan 12 21:55:47 RuckusAP daemon.notice rsmd[70]: nbrd ............ [stopped] (0.018)
Jan 12 21:55:47 RuckusAP daemon.notice rsmd[70]: nbrd ............ [started] (0.021)
Jan 12 21:55:48 RuckusAP daemon.notice nbrd[12079]: main,2153: pid=12079
Jan 12 21:55:48 RuckusAP daemon.notice nbrd[12079]: nbrd_init:RSM cannot get cluster ID! ret:6 bad key: wsgclient/cluster-name
Jan 12 21:55:48 RuckusAP daemon.notice nbrd[12079]: nbrd_init failed
Jan 12 21:55:48 RuckusAP user.err MsgDist[404]: MD try connection towards SCG-MD 
Jan 12 21:55:48 RuckusAP user.err MsgDist[404]: RCSL_Connect to 127.0.0.1 failed 
Jan 12 21:55:49 RuckusAP local1.info sessionMgr[410]: build_and_send_scg_init_req:243  Enter
Jan 12 21:55:49 RuckusAP user.err MsgDist[455]: Failed to route the message 
Jan 12 21:55:49 RuckusAP user.err MsgDist[455]: RCSL_MSG_HDR :  [Total Len = 57] [MsgType=RCSL_PUBLISH_MSG, srcMod=ap_sessmgr, dstMod=scg_sessmgr, dstHost=scg_host, Flags=0, UserKey=0xbeffb3f8, dstMac=0x0, srcMac=0x0, topic=0x0] 
Jan 12 21:55:49 RuckusAP user.err MsgDist[455]: DeliveryStatus flag is disabled. 
Jan 12 21:55:49 RuckusAP user.err MsgDist[455]: Route_Msg Failed 

Thanks!

1 ACCEPTED SOLUTION

syamantakomer
Moderator
Moderator

I see init failure in the support logs.

Could you check the AP certificate and also check if certificate check is enabled on controller or not.

If certificate of the AP is expired, you can disable the certificate check on controller, onboard AP and once AP is fully functional, you can enable the the cert check again.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

View solution in original post

5 REPLIES 5

syamantakomer
Moderator
Moderator

I see init failure in the support logs.

Could you check the AP certificate and also check if certificate check is enabled on controller or not.

If certificate of the AP is expired, you can disable the certificate check on controller, onboard AP and once AP is fully functional, you can enable the the cert check again.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

Forgot to share commands.

To check AP cert:

get rpki-cert issuer

To disable cert check on controller:

enable

configure

no ap-cert-check

end

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

THANK YOU SO MUCH!!!  This solved the issue!

@Windsor351 glad to know that issue has been fixed!

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI