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Imran_ruckus
Moderator
Moderator

Issue Description:

This issue may happen when your RUCKUS ICX-7150-C12P Switch starts running on the Routing code (SPR). The Switch should run on the Switching code (SPS) to avoid these issues for Lennar home users. Due to a power outage/power spike, the Switch boots up on the other partition which may be running on a ‘Routing Code (SPR)’ results in causing this issue.

 

Environment:

  • Product(s): RUCKUS ICX-7150-C12P
  • Software / Firmware Version: This could be on any version
  • Other Conditions: -NA-

 

Root Cause:

  • May be due to a power outage/spike or restart of the Switch.

 

Routing Code issue symptoms:

  • Slow/Intermittent Internet connection via RUCKUS devices.
  • Websites don’t load.
  • Devices getting disconnected or connectivity issues.
  • Internet connection keeps on dropping randomly.
  • Smart devices not being able to connect to the Internet.
  • RUCKUS ICX-7150-C12P Switch status in a ‘Disconnected or ICX Switch is Connecting’ state.

Process on how to diagnose if it’s a Routing code issue on CLI and how to fix it:

1.  First, we must identify the ‘current’ IP address assigned to the Switch by your local Internet Service Provider (ISP) Router to the RUCKUS ICX-7150-C12P Switch. Here is the guide on on How to find the IP Address of the RUCKUS Devices (Switch and APs) using IP Scanner free applications

Imran_ruckus_0-1703002183707.png

FIGURE 1 Switch Dashboard on a web browser to confirm it’s a Switch IP Address

2. Once we identify the IP address of the Switch proceed to access remotely the device “Command Line Interface” (CLI). Here is the guide on How to access the Command Line Interface (CLI) of the RUCKUS ICX-7150-C12P Switch

Once you access the Command line (CLI), it should look like the prompts below:

SSH@ICX7150-C12 Switch> (Accessing CLI using SSH option)

telnet@ICX7150-C12 Switch> (Accessing CLI using Telnet option when SSH doesn’t work)

OR

SSH@ICX7150-C12 Switch> (Switch – Indicate NO Routing Code issue)

Please enter the below commands once you log in to CLI to check the same:

Note: Hit Enter to accept each command

ICX7150-12P Router>enable

ICX7150-12P Router#show version

ICX7150-12P Router#show flash

There should be a similar output of the command with the SPR code as highlighted in FIGURE 2 to diagnose if it’s a Routing Code (SPR) issue.

Imran_ruckus_0-1700081000520.png

FIGURE 2 CLI Command output showing Routing Code issue

Solution:

If there is a similar output with SPR, please Enter the below commands in CLI to fix this issue:

Note: Hit Enter to accept each command

ICX7150-12P Router#enable

ICX7150-12P Router#copy flash flash secondary 

ICX7150-12P Router#boot system flash secondary yes 

Example VIDEO:

VIDEO LINK AS REFERENCE: https://www.youtube.com/watch?v=Eem1IBgYaWc

ICX7150-12P Router>enable (hit enter to accept the command)
ICX7150-12P Router#copy flash flash secondary (hit enter to accept the command and wait: until the flash finished)
ICX7150-12P Router#boot system flash secondary yes (hit enter to accept the command: the switch will reboot)

Once the RUCKUS ICX-7150-C12P switch reboots and comes online, should fix the issue. We can confirm by checking the version and other details by performing the same commands mentioned above.

Please post a query in RUCKUS Lennar Support if you need any assistance in this regard OR any other issues with the Lennar Home RUCKUS devices.

Thank you for visiting the RUCKUS Lennar Home Community Forum.

Version history
Last update:
‎04-23-2024 11:39 AM
Updated by: