cancel
Showing results for 
Search instead for 
Did you mean: 

Incorrect redirect for guest portal

brian_hoyt_6612
Contributor
I have a ZD1100 with 9.8.373 (I have R700) that I am having a guest portal issue with. When I connect to guest WLAN I do not get redirected properly to portal page on controller. If I type it in manually it works however. I have done packet captures on Wi-Fi interface of client and it appears the client is being redirected to wrong IP. Controller is .241 but the client gets .10 instead or gets the wrong DNS name. Is there somewhere in controller to configure DNS name rather than IP that it might be giving out improperly? Right now it just recursively gives out wrong redirect until it fails.

I have opened case with support but I thought I would see if others had any ideas.
7 REPLIES 7

edgar_ivan_moct
New Contributor III
Hello there!

Greetings from Mexico,

I had the same problem, but the issue its not with the controller itself, its the version.

I deployed in 3 different proyects using captive portal, but to work properly it's using the version "9.6.2.0 build 13" or any version "9.6."

regardless of controller you have.

brian_hoyt_6612
Contributor
I have to run 9.8 unfortunately though since I have R700 which are only supported with 9.8 and newer.

Were you getting redirected to incorrect page as well?

brian_hoyt_6612
Contributor
My problem was using a SAN cert it appears and the first DNS name in cert was used instead of correct FQDN. I removed / reset cert and the problem disappeared.

gordon_taylor_6
New Contributor III
i have this / similar problem its going to controller 1s dns name even when it has failed over to controller 2.  i used a wildcard certificate - i don't really want to buy 2 certificates just for guest portal...
Labels