cancel
Showing results for 
Search instead for 
Did you mean: 

Configuration on Cisco C3750 for ZF7982

yew_wei_chow
New Contributor II
I has problem on getting the DHCP from the AP for both users vlan on Cisco switch configuration. The AP manage to discover the ZD and AP are able distribute the SSID. The question is i'm not able to get any IP address when connected to both SSID.

From the Cisco configuration when i change to 'switchport mode access', AP will lost connection to ZD.

i have 3 VLANs:

80 - MANAGEMENT
81 - WIRELESS_STAFF
91 - WIRELESS_GUEST

Cisco IOS Software, C3750 Software (C3750-IPBASEK9-M), Version 12.2(53)SE2, RELEASE SOFTWARE (fc3))

!
interface GigabitEthernet5/0/12
description Connect_to_PutraWiFi_AP
switchport access vlan 80
switchport trunk encapsulation dot1q
switchport trunk native vlan 80
switchport trunk allowed vlan 81,91
switchport mode access
no cdp enable
spanning-tree portfast
!

Could someone help me to check whether the configuration are correct or I'm miss some step.
4 REPLIES 4

andrew_mccartne
New Contributor II
you need "switchport mode trunk" at the moment it is just an access port not trunking you only have Vlan 80 getting to the AP

you could also enter "no switchport access vlan 80" to tidy the config up.

Andy

yew_wei_chow
New Contributor II
Hi Andy,

Thanks for the info.

I has added the config as you advise but once change to switchport mode trunk the AP will lost connection to ZD. Below are the interface config:

interface GigabitEthernet5/0/12
description Connect_to_PutraWiFi_AP
switchport trunk encapsulation dot1q
switchport trunk native vlan 80
switchport trunk allowed vlan 81,91
switchport mode trunk
no cdp enable
spanning-tree portfast

Need your advice again. Thanks

andrew_mccartne
New Contributor II
have you configured at AP to have the ethernet interface as a Trunk Port. The untagged vlan 80. then in the WLAN group tag the staff and guest vlans 81 and 91

michael_brado
Esteemed Contributor II
switchport trunk native VLAN 80 # will untag VLAN 80

switchport trunk allowed vlan 80,81,91 # but you still need to allow VLAN 80 too
Labels