cancel
Showing results for 
Search instead for 
Did you mean: 

Optical monitoring not possible on ports with link down?

diego_garcia_de
Contributor III

Am I missing something or the optical monitoring only works when the link is up? I am trying to troubleshoot some fiber connections which were unreliable / not coming up and when I use the `show optical-monitor x/y/z` command, I get nothing. Just comes back to the prompt.

If the same port with the same optical module has link, then I do get a proper readout of the optical monitor command (tx power / rx power / temps / current).

Being able to monitor a non-working link is a pretty basic thing to do to be honest and having access to DDM/DOM/optical monitoring of down links lets you figure out if you have, for example, a broken fiber in one direction, a mis-plugged rx/tx pair, etc.

Is there any way to monitor the DDM/optical parameters while the link is down?

Thanks in advance!

1 ACCEPTED SOLUTION

hashim_bharooc1
Contributor III

Hi Diego,

The optical monitor shows signal levels, but will only show statistics if the port is up:

device(config)# show optic 2/1/1
Port Temperature Tx Power Rx Power Tx Bias Current
+-----+-------------+-------------+--------------+---------------------+
2/1/1 32.2578 C -002.5157 dBm -002.8091 dBm 5.966 mA
Normal Normal Normal Normal

If Signal is not correct and media type and fiber not right type link will not come up.
You need to check show media e x/y/z on both side make sure fiber is of right type.


Hope this helps.

If you need further help please open a  ticket and work with our TAC team.

https://support.ruckuswireless.com/contact-us

Thanks

Hahsim

View solution in original post

15 REPLIES 15

hashim_bharooc1
Contributor III

Hi Diego,

The optical monitor shows signal levels, but will only show statistics if the port is up:

device(config)# show optic 2/1/1
Port Temperature Tx Power Rx Power Tx Bias Current
+-----+-------------+-------------+--------------+---------------------+
2/1/1 32.2578 C -002.5157 dBm -002.8091 dBm 5.966 mA
Normal Normal Normal Normal

If Signal is not correct and media type and fiber not right type link will not come up.
You need to check show media e x/y/z on both side make sure fiber is of right type.


Hope this helps.

If you need further help please open a  ticket and work with our TAC team.

https://support.ruckuswireless.com/contact-us

Thanks

Hahsim

Hi Hashim,

thanks. Its not really useful to be honest, as in my case, the media matches on both ends but the link is not coming up. Especially when running a link across campus, you can't always trust the fiber plant (As its my case at the moment)

On other vendor's switches I was always able to show DOM/DDM/optical-monitoring parameters for ports in down state which can help a lot to troubleshoot why the link is not working.

In fact, one would argue that there is very little use for DOM when the link is up and ok. If my interface is not coming up because my RX power is too low, I want to be able to see that.

Thanks in advance

hashim_bharooc1
Contributor III

Hi Diego,

The optical monitor shows the signal.  If port is down it will not display the signal.

You can use show media x/t/z and show int e x/y/z  for the port in question.

Please paste the above two outputs, as well as show version show mod and show license for your switch.

Thanks

Hashim

diego_garcia_de
Contributor III

Hi Hashim,

As I mentioned before, I have used this exact feature on other vendors (with link down I mean). I can see, for example, rx power for an un-plugged optic at -40dbm for example. Which pinpoints to a broken fiber for example or a reversed rx-tx pair.

Also its very useful when a link is on the verge of working / not working like when you have too much attenuation on the link

For example, if my link is flapping becasue im at -14 / -15 dbm.. i can only see that if I get to catch the "show optic" command at exactly the time that the link is up.

Or, if im having issues with a link, seeing its voltage or temperature can be a  very helpful troubleshooting step.

I will try to get the show commands asked for tomorrow.

But it feels like I'll have to open an RFE to see if it will be possible to get it in a future release.