cancel
Showing results for 
Search instead for 
Did you mean: 

ICX 7150 to Ruckus ZD1200 w/H510 WAP

p_tech
New Contributor III
hello Newbie question.
I am trying to connect a ZD1200 via an ICX 7150 switch to H510 APs.
 vlan 1 is native /Vlan 20 public ssid /Vlan 30 for members / Vlan 40 for media and Vlan  100 for wired connections.

I have the following config but unable to get the ZD on port 1/1/1 to connect to the APs on ports 1/1/3 - 1/1/12.

The source internet port is 1/2/1

-------------------------------------------------------------------
!
ver 08.0.61aT213
!
stack unit 1
  module 1 icx7150-24p-poe-port-management-module
  module 2 icx7150-2-copper-port-2g-module
  module 3 icx7150-4-sfp-plus-port-40g-module
!
!
!
!
!
vlan 1 name DEFAULT-VLAN by port
!
vlan 10 by port
 tagged ethe 1/1/1 ethe 1/1/11
!
vlan 20 by port
 tagged ethe 1/1/1 ethe 1/1/3
 router-interface ve 20
!
vlan 30 by port
 tagged ethe 1/1/1
 router-interface ve 30
!
vlan 40 by port
 tagged ethe 1/1/1
 router-interface ve 40
!
vlan 100 by port
 tagged ethe 1/1/1 ethe 1/1/7
 untagged ethe 1/1/8 to 1/1/9
 router-interface ve 100
!
!
!
aaa authentication web-server default local
aaa authentication login default local
boot sys fl sec
no ip dhcp-client auto-update enable
ip dhcp-server enable
no ip dhcp-server mgmt
!
ip dhcp-server pool public
 dhcp-default-router 172.16.1.1
 dns-server 8.8.8.8
 excluded-address 172.16.1.1
 lease 0 1 0
 network 172.16.1.0 255.255.255.0
 deploy
!
!
ip dhcp-server pool members
 dhcp-default-router 172.16.2.1
 dns-server  8.8.8.8
 lease 0 12 0
 network 172.16.2.0 255.255.255.0
 deploy
!
!
ip dhcp-server pool media
 dhcp-default-router 172.16.3.1
 dns-server  8.8.8.8
 lease 0 4 0
 network 172.16.3.0 255.255.255.0
 deploy
!
!
ip dhcp-server pool vlan100
 dhcp-default-router 10.10.64.1
 dns-server 10.10.64.1 8.8.8.8
 excluded-address 10.10.64.1 10.10.64.50
 lease 1 0 0
 network 10.10.64.0 255.255.254.0
 deploy
!
ip default-network 10.10.64.0/23
ip dns domain-list CI_LA
ip dns server-address 10.10.64.1 8.8.8.8
ip route 10.10.64.0/23 ethernet 1/2/1
ip route 172.16.1.0/24 ethernet 1/2/1
!
!
!
!
!
!
!
!
!
!
interface ethernet 1/1/1
 dual-mode  10
!
interface ethernet 1/1/3
 inline power
!
interface ethernet 1/1/4
 inline power
!
interface ethernet 1/1/5
 inline power
!
interface ethernet 1/1/6
 inline power
!
interface ethernet 1/1/7
 inline power
!
interface ethernet 1/1/8
 inline power
!
interface ethernet 1/1/9
 inline power
!
interface ethernet 1/1/10
 inline power
!
interface ethernet 1/1/11
 inline power
!
interface ethernet 1/1/12
 inline power
!
interface ethernet 1/3/2
 speed-duplex 1000-full
!
interface ethernet 1/3/4
 speed-duplex 1000-full
!
interface ve 20
 ip address 172.16.1.1 255.255.255.0
!
interface ve 100
 ip address 10.10.64.1 255.255.254.0
!
!
interface ve 30
 ip address 172.16.2.1 255.255.255.0
!
interface ve 40
 ip address 172.16.3.1 255.255.255.0
!
!
!
!
!
!
!
end

 
21 REPLIES 21

syamantakomer
Moderator
Moderator

Hi,

Could you please confirm what VLAN you wish to use for AP and ZDs?

It seems you want to use VLAN 100 for ZD and AP (Since you have mentioned VLAN 100 for wired), if that is the case then the only missing configuration for VLAN 100 is:

-        Set the interface 1/1/1 and 1/1/3 to 1/1/12 in dual mode with VLAN 100

For VLAN 100 you already configured a VLAN interface, a DHCP pool, and IP route to gateway interface 1/2/1.

VLAN 10 is not even configured on any of the VLAN interface, so I think above should work.

Hope this will work.

Regards

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

david_ellis_h2n
New Contributor II
The port for the ZD does not need to be tagged in any VLAN. It only needs to be untagged in your management VLAN (I assume VLAN 10). It will work the way it is setup, but it is not a best practice.

For the H510, You need to tag ports 1/1/3 to 1/1/11 on VLANs for the wireless, management, and wired ports on the AP. You will need to set the VLAN for the wired ports on the H510 as your Dual-mode VLAN, and configure the management VLAN in the AP configuration of the ZD.

Example:

VLAN 10 (Assumed Management)
untagged e 1/1/1 - ZD Port

VLAN 10 20 30 40 100
tagged e 1/1/3 to 1/1/11

int e 1/1/3 to 1/1/11
dual-mode 100

Configure management VLAN of the AP in ZD to 10

bruce_o_donnell
New Contributor
Hi P-Tech

Another thing I notice is you have routes defined on interface 1/2/1 but no IP address assigned. This will be insufficient to work. You need to either assign an IP address to eth 1/2/1 which will make it a routed port (consider use of route-only command in that case on 1/2/1) or preferably use another VLAN and asign it untagged on eth 1/2/1 with the routes pointing to the corresponding VE.

For extra brownie points, consider
int eth 1/1/3 to 1/1/12
port-name WAPs

int eth 1/1/1
port-name "SZ1200 ctrlr"

or similar.
This will make it easier to follow in the future what you intended.
Also, use
show vlan
or show vlan eth x/y/z to understand better what your current config is achieving. The output is a little hard to follow at first but it is comprehensive.

btw the dual-mode 10 on eth  1/1/1 was perfectly valid but as David Ellis says, you don't need any other VLAN so untagged or dual mode much of a muchness.

Also maybe the below
vlan 10 by port
 tagged ethe 1/1/1 ethe 1/1/11
was supposed to be
vlan 10 by port
 tagged ethe 1/1/1 to 1/1/12
What about a management ve for VLAN 10 so you can talk to the controller and what of address assignment for APs? These are not in align atm.

Hope this helps.

p_tech
New Contributor III
Apologies for the delayed response due to illness . Thank you all for your assistance and will update you shortly