cancel
Showing results for 
Search instead for 
Did you mean: 

Clients roaming at very high rate

Wouter
New Contributor

So we have a quite large campus network (1000 units) with every unit of around 25 square meters (270 sq ft) having a H510. This as a retro-fit so the AP's location are not very optimal centered but during the site survey we notices we could still use 1/10th of transmit power to achieve >-65dbm in the entire unit. Sometimes neighboring ap's are still at acceptable levels of around -75 to -65 which is nice in case an AP goes down. (we have some down, users don't complain often). As we use DPSK for all tenants this shouldnt be a problem, we sometimes notice some devices pick the AP next door at proper signal levels.

However, we notice some clients are roaming extremely agressive, up to 10 times per minute. This results in close to unusable connections most of the time. From my memory usually windows devices. In the event log we see alternating rows with code 209 and 236. Even roaming to AP's which should have levels way below -75dBm with 1 or 2 extra units in between. It's like the client wants to be friends with every AP it can see.

Is there any info on what initiates this behaviour? Usually if we suspect a crap wlan nic I provide users a TP Link usb dongle just to rule out a crap wlan nic. However, I noticed this behaviour on these usb dongles as well. Main question is:

Is this a typical decision from the windows OS or is this really a driver thing and might the TP-Link T3U have the same issue?

Most recently I asked a user what NIC they have, it's a Realtek RTL8822CE. She was running windows 11 so I figured out it should have a lot of recent drivers as well.

The problem lies with client devices but if there's a proper solution for this behaviour and a cause that would be nice to provide some support for our users to help them out or they can report to the manufacturer that x, y and z are broken on their device and they would like some support. On the realtek case we set the roaming agressiveness to 'disabled' which fixed things so far, however a low or medium-low would suit a lot better as it would still do roaming.

2 REPLIES 2

syamantakomer
Moderator
Moderator

Hi Wouter,

If APs are close to multiple APs with good signal strength, you can try BSS min rate setting.

Set it to 12Mbps and see if it stabilizes the network.

Regards,
Syamantak Omer
Official Rep | Staff TSE | CWNA | CCNA | RASZA | RICXI

@syamantak_omer Thanks for the tip, we're using OFDM only and probably will try this on 5g, should prevent excessive roaming in higher density environments like this.

However, I noticed that for some reason the RSSI on this specific case would be too low so I will also check the AP (it reports 20dBm lower RSSI compared to others), it might be broken and be the cause of excessive roaming. Increasing Tx power to full seems to have no effect...