cancel
Showing results for 
Search instead for 
Did you mean: 

Is it possible to use guest access without ssl cert. for ZD1200 9.13.3.041 firmware?

alan_tam_ell5st
New Contributor III
Hi,
    I would like to know is there anyway to assign guest access with using SSL cert. Because, when I setup guest access with no authentification. I set redirect page to www.google.com. When test on guest access, the google page will show "Your connection is not private error.". The user can not browse internet.

  Is there anyway to setup guest access without ssl cert and let guest browse internet using http?

Thanks.

Best regard.

Alan
11 REPLIES 11

DarrelRhodes
Contributor
Hi Alan,

Try setting your redirect page to a non-HTTPS page and you should see the SSL cert error go away.

Thanks,
Darrel.

alan_tam_ell5st
New Contributor III
May I know how to do it. Currently I set redirect page to www.google.com. Because all my guest access got the error "Your connection is not private" even when they key in URL manually also saw this error. They can not browse to any website. Do I need to cli to zone director to disable HTTPS redirect? If the answer is yes, how do I cli to zd using LAN cable?

Thanks for your value reply.

Thanks.

Alan

DarrelRhodes
Contributor
Hi Alan, 

Try setting your Captive Portal redirect page to a NON-HTTPS site.  There's not many of these left but I've found a list here: https://whynohttps.com/
e.g. www.espn.co.uk

This is because one of the functions of HTTPS is to alert the user if they have been forcefully redirected. 

If you are still having issues after making the change please paste an image of your guest access configuration.

Thanks,
Darrel.


pasquale_monard
New Contributor III
or let CNA takeover, it is on these devices for a reason to make that port 80 web request for you so that an error free experience can happen. 

To build on Darrel's point. If you are asking users to sign into a captive portal then you are asking your users to be redirected to you. Now when visiting an HTTPS website (ie. google.com, facebook.com) your browser will expect to see the proper certificate for that website but instead it is being told to go to your ZD captive portal page and the certificate does not match google.com or facebook.com that is why you get the SSL error.

1. Make sure your redirect is non-https
2. Make sure CNA works properly. this is the little popup browser you get when connecting to a WLAN that has a captive portal.