cancel
Showing results for 
Search instead for 
Did you mean: 

R610 ZD Firmware Upgrade "bad firmware header magic"

ihopethisworks1
New Contributor II

Hello all,

I am trying to upgrade the FW on my R610 AP to ZD1200 and every time I try and upgrade I get a "bad firmware header magic" error. This happens if I try to do it through TFTP and locally on the WebUI, and I even tried to do it through the CLI and getting the same error along with a Bad File message.

I'm using the latest ZD file from the Ruckus website: zd1200_10.5.1.0.176.ap_10.5.1.0.176.img, so I'm not sure why it would be a bad file.

 

Does anyone know what can be causing this and if anyone has had success putting the latest ZD 1200 image onto their R610 AP?

 

Any help would be appreciated!

Thanks

2 ACCEPTED SOLUTIONS

Hello Vineet,

get director gives the following

- ------ ZoneDirector Info ------
Primary Controller : n/a
Secondary Controller : n/a
DHCP Opt43 Code : 3
AP is in Stand-alone mode.
OK

which I believe means the AP does not see the ZD at all.

 

The log is producing the same error throughout the logs: RuckusAP daemon.err wsgclient[541]: curl_https_request:889 Address [RuckusController] is invalid address.[-2]

The AP and ZD are on different subnets but should be able to communicate to each other.

Any ideas?

Thanks!

 

View solution in original post

@ihopethisworks1 

The AP should get the ZD IP via DHCP option 43 or DNS entry if you want it to automatically get it (these two needs to be configured on DHCP server). Currently I doubt you have configured any as AP has no information of controller IP hence you can alternatively do a manual command to point AP to the ZD's IP by below :

set director ip <ZD IP>
reboot

Best Regards

Vineet

View solution in original post

8 REPLIES 8

Vineet_nejwala
Moderator
Moderator

Hi @ihopethisworks1 

The image you are using is an ZD image and will not work on AP. You would need to upgrade AP to stand alone code and then it would talk to ZD and upgrade to ZD image. Please be noted since 10.5. AP and ZD image upgrade is done via port 443 so make sure it is not blocked.

https://support.ruckuswireless.com/software/2787-ruckus-solo-access-point-114-0-0-0-6565-ga-software...

Best Regards

Vineet

Thanks for the response, I was able to put upgrade the AP, but I'm not seeing it on the ZD. I've made sure the networking is setup correctly, but for some reason the ZD does not detect the AP.

Can you attach the output of below command from AP:

get director

get syslog log

Best Regards

Vineet

Hello Vineet,

get director gives the following

- ------ ZoneDirector Info ------
Primary Controller : n/a
Secondary Controller : n/a
DHCP Opt43 Code : 3
AP is in Stand-alone mode.
OK

which I believe means the AP does not see the ZD at all.

 

The log is producing the same error throughout the logs: RuckusAP daemon.err wsgclient[541]: curl_https_request:889 Address [RuckusController] is invalid address.[-2]

The AP and ZD are on different subnets but should be able to communicate to each other.

Any ideas?

Thanks!

 

Labels